Skip to main content

OnlineSupport4u

“chown: Invalid username: root:Disk”

By Prasad Naik
April 3, 2017

The server was not allowing login to server even when ssh keys were saved On rebooting server I could see it and error on screen “chown: Invalid username: root:Disk” On troubleshooting found error to be due to corruption of /etc/passwd  as this is where all users are saved and due to corruption the user  root […]

Read More

Parse html as PHP is easyapache 4

By Prasad Naik
March 27, 2017

  Normal rule in .htaccess to parse html files as php on easyapache 3 are not working on easyapache 4 #AddType application/x-httpd-php .php .htm .html #<FilesMatch “\.(htm|html|php)$”> #SetHandler application/x-httpd-php56 #</FilesMatch>   Below is the code which will need to be added In cpanel, multiphp manager will add the following for force a specific version of […]

Read More

[RVSiteBuilder] Cannot connect using curl_init

By Prasad Naik
March 24, 2017

While working on one of the issues came across the error  cannot connect using curl_init in rvsitebuilder The issue was a simple fix by skipping DNS checking by creating below file using command touch /var/cpanel/rvglobalsoft/rvsitebuilder/var/skip_validate_domain The issue got resolved with this fix    

Read More

DNS error bad owner name (check-names) /tmp/cpanel

By Prasad Naik
March 16, 2017

While working with one client I was getting below error in DNS DNS error bad owner name (check-names) /tmp/cpanel So I went ahead and checked DNS zone file using below command   root@vps [/var/named]# named-checkzone onlinecsource.com /var/named/onlinesource.com.db /var/named/onlinesource.com.db:56: _autodiscover._tcp.cheapsalesleads.onlinesource.com: bad owner name (check-names) /var/named/onlinesource.com.db:57: _autodiscover._tcp.cheapsalesleads.onlinesource.com: bad owner name (check-names) zone onlinesource.com/IN: loaded serial 2017030209 OK […]

Read More

Sorry, the domain xx.xx.104.in-addr.arpa is owned by another user (nobody)

By Prasad Naik
March 6, 2017

While adding rDNS file in cpanel server I was getting below mentioned error Sorry, the domain xx.xx.104.in-addr.arpa is owned by another user (nobody) I have found that at one point in the past this domain was present on this server. I have removed remnants of the domain from /var/cpanel/users/system and removed references to it from […]

Read More

Ignore table and dump mysql database

By Prasad Naik
January 20, 2017

-bash-4.1# mysqldump satmn13_drup189 > satmn13_drup1891.sql mysqldump: Got error: 1146: Table ‘satmn13_drup189.dr_cache_admin_menu’ doesn’t exist when using LOCK TABLES -bash-4.1# mysqldump satmn13_drup189 –ignore-table=satmn13_drup189.dr_cache_admin_menu > satmn13_drup1891.sql

Read More

Incorrect DiskSpace and Information in cPanel

By Prasad Naik
October 26, 2016

While working on one clients vps for incorrect disk usage  stats for mails While the default cpanel has no emails the usage stats showed 750MB. After going through I found a issue which was causing this The file causing this issue was maildirsize maildirsize is the file which shows stats information for each account root@vps […]

Read More

Emails going to Spam folder issue

By Prasad Naik
October 19, 2016

We do get complaints of emails going to spam folder most of the times while working. The solution to such a issues depends on 3 things rdns for the IP address and matching A record for the domain name in question. Need to setup right SPF Need to setup right DKIM a) To setup SPF […]

Read More

E-mail accounts not showing in cPanel

By Prasad Naik
October 12, 2016

The issue when you open “Email accounts” in cPanel, it sometimes doesn’t show up the list of Email accounts the domain have but only just a blank page without any email account No Email Accounts”! This happens due to bulk of cache, temp files etc present in the .cpanel directory of domain. In order to […]

Read More

Softacalous blank issue cPanel/WHM

By Prasad Naik
September 15, 2016

While working one of the clients server We saw an issue where going from WHM > plugin > Softacalous and opening it resulted in blank page. The issue is due to corrupt files in softacalous. To fix this issue softacalous need to be reinstalled to reinstall to go cd  /usr/local/cpanel/whostmgr/docroot/cgi/ rm -rf softaculous cd /home […]

Read More

Error: Cannot retrieve metalink for repository: epel. Please verify its path and try again

By Prasad Naik
September 9, 2016

While working on a server on installing php 5.6 on centos 6 OS I was getting error “Error: Cannot retrieve metalink for repository: epel. Please verify its path and try again” After googleing around I found this issue is due to https mentioned in the .repo file in /etc/yum.repos.d [root@host yum.repos.d]# ls -la total 28 […]

Read More

cPanel – Can’t change hostname

By Prasad Naik
August 27, 2016

While setting hostname from WHM  >>  Change Hostname We were seeing below error “The hostname was already set to server1k.online.net, syncing configuration only. Error setting new hostname: Could not execute hostname binary Could not set property: Connection timed out” After googling found a alternate solution to this via cli The command was   /usr/local/cpanel/bin/set_hostname  <hostname> It […]

Read More
1 10 11 12 19